Errors with checking challenges completed in Playgrounds - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Kimberley ScrivenKimberley Scriven 

Errors with checking challenges completed in Playgrounds

Hi! Anyone else complete a challenge and then told the changes you've made can't be seen...even though you're looking right at them?! Any suggestions? I've tried re-launching and going back steps, still getting the same issue? Currently on 'Get Started with Enterprise Territory Management'
Thank you
Best Answer chosen by Kimberley Scriven
Kapil BatraKapil Batra
Hi Kimberley,

Give it a try in a new playground !

All Answers

Guy KeshetGuy Keshet
Hi Kimberley

Territory managment is about extending visibility of salesfroce records.
the fact you can see the changes does not necessarily menas other users can

typcially when you receive an error as you describe below, that means that the test user cant see the changes, which typcially points to an issue with secuiry setup - be it profile/permission or sharing

It's fairly common in implementaiton projects as well - developers work in sys admin mode and sometimes forget that users have restrictions that may prevent them form seeing changes.

To be 100%, use a user profile that is not a sys admin to test your changes
Kapil BatraKapil Batra
Hi Kimberley,

Give it a try in a new playground !
This was selected as the best answer
Rets'elisitsoe 'MolaoaRets'elisitsoe 'Molaoa
Hi Kimberly

Have any of the suggested solutions worked as am faced ith the same issue.?
Laura TaylorLaura Taylor
I started having the same issue this week and can't see where to create a new playground.
Scott SkillmanScott Skillman
I have the same issue with "Loan Amount" - 
in 
Challenge not yet complete in My Trailhead Playground 1
The field 'Loan_Amount__c' either does not exists on the Contact object or it is not of type currency.

Here is the rejection 
User-added image

Here is where it shows I have completed the item

User-added image
Allena McGlaughlinAllena McGlaughlin
I had the same problem the other day, and I created two new playgrounds and re-did all of the work on both, and it still wouldn't acknowledge it, so I gave up.
Kimberley ScrivenKimberley Scriven
UPDATE: I Started a new playground and it seemed to work fine -what's more annoying is nothing was different when i did the same steps in the next playground! However, when i went to the next project level, the same issue happened. Sorry Salesforce, haven't time to do each step in each new playground. Very annoying as it seems with the more complex modules seem to create this issue. 
Matthew MacMinnMatthew MacMinn
I had the same issue today, and I am currently working through the 10 steps to get to this challenge in a new playground. But it's arduous and if it doesn't work, I can't go back every time I need to complete a new challenge to retrace everything. Love Trailblazer, but this bug seems a bit frustrating.