Lightning for Outlook Error - Couldn't validate the Exchange identity token - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Bryan LehnertBryan Lehnert 

Lightning for Outlook Error - Couldn't validate the Exchange identity token

User-added image

This error is coming up after login to the Lightning for Outlook add in. It is only occuring for some users, others are able to get through successfully. I have searched and not found a lot of information on the error, does anyone have a solution?
Best Answer chosen by Bryan Lehnert
Mario PasambaMario Pasamba
We reset the Microsoft Exchange password for one of our users and that worked for them.  Since it refreshed the toekn, it seemed to have been the issue.  Will reset others and will report back if that is indeed the fix.  A sucky fix, but a fix.

All Answers

Cece LoftCece Loft
Same problem here.  I found a known issue that looks the same from August 2018, but can't find a solution. 
Mario PasambaMario Pasamba
Same problem here as well.  Some users had this issue, I as an admin also had this error message come up but after restarting Outlook I was able to connect.  This did not work for one of my users.  But everyone that logged in today and tried to connect had to re-login.
Cece LoftCece Loft
Restart did not work for me, and I am an admin as well.
Bryan LehnertBryan Lehnert
I also tried restarting a few times, did not work.
Christopher BussoChristopher Busso
I'm having the exact same issue. I found this issue that seems isolated to German Exchange Servers last summer, but that was supposed to have been fixed ( I tried this proposed solution of logging in via Exchange Web Mail but I recevied the same message.
Yvette HallidyYvette Hallidy
I've also encountered this error along with some other users and have not been able to resolve it yet. I also tried to restart. 
Nick BelliaNick Bellia
Same problem. Forced to manually push emails into salesforce with my email token. 
William PetterssonWilliam Pettersson
We are havng the same problem.  I have removed the Add-in and reinstalled that does not work either. 
Jordan SirotaJordan Sirota
We are having the same problem, we have attempted reinstalling the add-in as well.
Zachary McAuleyZachary McAuley
Yup- same issue has just been reported by users at my institution. 
Elise FranchiElise Franchi
Following--also having this issue intermittently. Unistalled and reinstalled the LFO add-in and it worked for one user. Trying to repeat with the others--not sure if it will work across the board. 
Kumar VikashKumar Vikash
Several users in my org have reported this issue. I have raised a case with Salesforce, but yet to hear back from them. 

Also, this has not yet come shown up on their Trust Status(
Sean WylieSean Wylie
We also had this reported by a user.  Will open a case.  Eager to hear if anyone gets a resolution. 
Richelle HennenRichelle Hennen
I have many users who have reported this issue, and I have also raised a ticket with Salesforce. We'll see who has a resolution first!
Dan ShermanDan Sherman
Ditto - Tried removing and adding inbox for salesforce but that required a different license.  Changed it back and still have the same token error.
Mario PasambaMario Pasamba
We reset the Microsoft Exchange password for one of our users and that worked for them.  Since it refreshed the toekn, it seemed to have been the issue.  Will reset others and will report back if that is indeed the fix.  A sucky fix, but a fix.
This was selected as the best answer
Jeremy HashiguchiJeremy Hashiguchi
Same issue - just started this morning, several of our users were logged out and cannot log back in with this error showing. We have a case open with Salesforce, however, in the meantime, we tried resetting the Microsoft Exchange password as Mario suggested, and that did work as a fix to get us back in. Thanks!
Travis ThompsonTravis Thompson
Same issue
Minna ShirleyMinna Shirley
Same issue - started a case. 
Stephanie LeachStephanie Leach
Just finished resetting my Microsoft Exchange Password. I was able to login to LFO, but did not pin the sidebar open. When I went to open it again, it would not connect - same issue. I have a case open with tech support. 
Megan McDonaldMegan McDonald
Also have a user reporting the same issue. Will log a case. 
Alex WaxmanAlex Waxman
Same issue here. 
Sean TraceySean Tracey
Logged a case as well - suggested workarounds above aren't working for us. Does anyone know what the magic # of complaints are before SF acknowledges the problem?
Cece LoftCece Loft
I submitted a ticket this AM, and have received a response similar to the item @christopherbusso mentions above. They have asked me to give details, as they have no known fix at this time
Jeremy HashiguchiJeremy Hashiguchi
Just got off the phone with Salesforce Support and they provided the following fix:
  • In Outlook Desktop select File and then under Account Settings, select the link under the bullet "Access this account on the web" (it should be an outlook.office365 link). We used Chrome, but that didn't seem like it would make a difference.
  • Select an email in the Outlook Web instance and in the top right, select the three dots drop down. Select  Salesforce from the drop down and you'll be prompted to enter your credentials.
  • Enter credentials and confirm Salesforce with Outlook Web
  • Go back to Outlook Desktop and close the Salesforce tab and re-open - everything should sync up and work at this point
We tested on the call and it worked for one of our users. Hope this helps others too!
Christopher BussoChristopher Busso
I just tried the same steps that Jeremy Hashiguchi suggested above and it works for me.  I don't know why it worked now when it didn't work this morning.
Trevor MurrayTrevor Murray
I tried the steps suggested by Jeremy and didn't have success 
Bryan LehnertBryan Lehnert
Just tried Jeremy's suggestion and it did not fix for me. 
Richelle HennenRichelle Hennen
I also tried those steps with the Outlook Web, and they did not work. I've tested the other solution, to reset the Microsoft Exchange password, and that has worked with myself and another user. I'm hesitant to ask my users to do this, though, since that password is used as the main network password.
William PetterssonWilliam Pettersson
When trying the steps from Jermey I get this message:

Something went wrong
The mailbox being accessed doesn't have a valid account state ('ProtocolDisabled').
More details...
Refresh the page
William BixbyWilliam Bixby
Can anyone else get back in if you keep trying to authenticate?  I can replicate the issue by loggin out and have fixed it numerous times by inputting my credentials over and over again until it works. 

The highest count I got to was 8 tries and the average was 3-4.
Richelle HennenRichelle Hennen
Out of curiosity, did anyone else have a Microsoft 10 update run on their computer? Trying to verify if this actually correlates.
Bryan LehnertBryan Lehnert
My last Win10 update shows 11/19 with nothing pending, so does not seem to be the problem in my case.
Zachary McAuleyZachary McAuley
Don't think it is windows related, as it is also happening on Macs here. 
Minna ShirleyMinna Shirley
Just followed Jeremy Hashiguchi's steps (office365 weblink) and had success! Not sure why it was successful, but I will try to repeat with a few of my users.
Kirill KamayevKirill Kamayev
After multiple tries I am able to get in, but lossing connection almost instantly. 
Violeta TorresVioleta Torres
Same issue is happening also an admin. This could be a Office 365 issue.
Jennifer OrtizJennifer Ortiz
Following for resolution.  When you hear back from your cases with Salesforce, can you update the thread please!  Thanks all!
Sean TraceySean Tracey
Had a call with an engineer about an hour ago - he claimed it was an issue with Microsoft making some kind of authentication change and this was only affecting users on Office 365. He wanted to have a follow-up scheduled for tomorrow morning to collect logs from a few affected machines as they apparently aren't sure why this is happening.
Richelle HennenRichelle Hennen
The Salesforce support agent on my case said that it looked to be something similar with Microsoft that had happened back in 2018. The only solution we have found to work at this point is the password reset.
Ankit GargAnkit Garg

I have tried Jeremy Hashiguchi's steps but it didn't work. 
Thanks Richelle.
We had all of our users reset their Exchange password which has resolved the problem.
Minna ShirleyMinna Shirley
My Exchange password reset appears to be holding as a fix. I just tested with one of my users (prompted by Salesforce support agent on my case) and confirmed that the fix also worked for her. It's a pain, but it appears to be working.
Ankit GargAnkit Garg
Resetting the password has solved the issue. 
Violeta TorresVioleta Torres
What worked for my organization was deleting the Salesforce add-on from the exchange admin portal and deploying the add-on from the new office 365 admin portal.
Cece LoftCece Loft
On the case I submitted, Salesforce is pushing me to run the debug tool so they have more information, but they have not given a solution. Resetting password worked for one user, we may just go that route and solve this without help. Dissatisfied with Salesforce support on this issue.
William PetterssonWilliam Pettersson
Our users logged in today and everything is working.  Someone must have fixed the issue.
Clint BourgeoisClint Bourgeois
We are seeing this issue with some users, too.
Sean TraceySean Tracey
Seems we're all up and running today - SF engineer called this morning and said the issue had been resolved last night in working with Microsoft. The process we've gone through today was
  1. Login to LFO - get error message
  2. Quit Outlook completely, verify closed from Task Manager
  3. Launch Outlook, login to LFO
  4. Profit!
Pretty odd that it only seems to work once you've failed then relaunched Outlook, but it must be some kind of cached info that gets cleared when you relaunch.
Tanu DuaTanu Dua
Please Asnwers my question---
This Issue faced by globally !! Lots of users facing the same issue in our org.
Anyone know about this what is the reason for this issue?
Now it this issue has been resolved ?
Tanu DuaTanu Dua

@Kumar Vikash Yesterday , You had capture any screenshot form Salesforce site. If you have so please share with me.
Charlie PlumblyCharlie Plumbly
Steps below that might resolved your issue.

In your Salesforce account, please follow the path below:
PATH: Salesforce | Setup | From the quick find search, type in Outlook Integration | Look for the User Mapping | Revoke or delete your Login

After that, go to your Outlook Web Application and try to login again to the Salesforce sice panel. Go back to your Outlook Desktop Version, and try to login.
Jeff SternJeff Stern
Did anyone figure this out? I have had this issue for 2 weeks. I have changed my outlook and salesforce passwords and no luck. It is working on Microsoft 360 (web version of outlook) but not outlook for Mac. Thanks in advance!