"Switch to Lightning Experience" link is not available for one user in my org - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Stephen BisherStephen Bisher 

"Switch to Lightning Experience" link is not available for one user in my org

I have enabled Salesforce Lightning for everyone in my organization, but I have one user who cannot seem to get the "Switch to Lightning Experience" link to show in Salesforce Classic. I double checked the following:
  • Lighting Experience Transition Assistant: I ensured that their user account is added under the "Switch Users to Lightning Experience" option under the "2. Rollout Phase" -> "4. Launch Lightning Experience" menu.
  • Profile: The Profile assigned to this user has "Lightning Experience User" checked.
  • Permissions Sets: the permission set assigned to this user also has "Lighting Experience User" check (which is found under the System Permissions section for the Permission Set).

However, with all of these settings enabled, they still cannot see the "Switch to Lightning Experience" link at the top of Salesforce Classic. No one else in my organization has had this problem in being able to view the Lightning link. Does anyone have any recommendations on what I should investigate next?

Thank you!

Best Answer chosen by Stephen Bisher
Maxim MakarenkoMaxim Makarenko
Now, this sounds like a 98%-chance of a browser-related error. Let the user try a few different browsers and/or login properly from your machine and see if that changes anything.

All Answers

Rejith VarmaRejith Varma
Hi Stephen

Did you check this discussion? - https://developer.salesforce.com/forums/?id=906F0000000kK1kIAE

best regards
Rejith
Maxim MakarenkoMaxim Makarenko
Hi Stephen, does this user see the LEX Transition Assistant when they go to Setup?
User-added image
Stephen BisherStephen Bisher
Hello Maxim,

Good question, I checked and the user does not see the LEX Transition Assistant when they go to setup.

Even stranger, when I use the Login option via Setup->Manage Users->Users to login to this users account, Salesforce Lightning is the default login with the option to switch back to Classic. However, when the user logs in on their own, they are stuck in Salesforce Classic with no option to switch over. Any idea why we would be seeing differences between my login and their login?

Reijith, I tried looking at the forum post you linked, but since the LEX Transition Assistant is completely missing from this user's account, I cannot follow the resolutions described there.
Maxim MakarenkoMaxim Makarenko
Now, this sounds like a 98%-chance of a browser-related error. Let the user try a few different browsers and/or login properly from your machine and see if that changes anything.
This was selected as the best answer
Stephen BisherStephen Bisher
Great suggestion Maxim! That was exactly the issue, this user was using IE 11. I asked them to try Microsoft Edge and the issue is now resolved. Thank you for pointing me in the right direction.
apollo tvapollo tv
Very well explained, couldn't have asked for a better solution. Thank you so much!

Regards, Apollo Tv (https://apollotvapk.com/)