OAuth Error - We can't authorise you because of an OAuth Error - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Grace SelleyGrace Selley 

OAuth Error - We can't authorise you because of an OAuth Error

Hi,

One of my users is struggling to log in on a new computer, receiving this error message:

OAuth Error
We can't authorise you because of an OAuth Error. For more information, contact your Salesforce administrator. You didn't complete the approval process before it expired, please try again. 

The activation code is coming to their email and they are entering it almost immediately. Any ideas why they would be receiving this error??

They work at a different site, so I'm not able to try other logins at their PC. 

Thanks!
Best Answer chosen by Ed (salesforce.com) 
Christian LoewChristian Loew

Not sure if this will help the rest of oyu but I had this same issue suddenly happen to me.  Internally we're developing our new software platform with OAuth authentication as well and what i realized is that there seemed to be some conflict between my login to THAT application and SalesForce (TrailHead).

 

I fully logged out of our new internal application and then was able to log into TrailHead no problem.

 

So, see if you or your users are logging into another OAuth related application, or make sure they are FULLY logged out before attempting their login again.

All Answers

Jeff MayJeff May
It could be almost anything. I would suggest reviewing the OAuth configuration you have in place, and double check that user specifically.  Try comparing that user's config with a user that is successful with OAuth usage.
501 Commons Admin501 Commons Admin
Grace,
Did you solve this? I'm having exactly the same problem and the user is configured identically to other users.
Travis LittleTravis Little
Grace and Zach,

Were either of you able to solve this? I'm having the same issue with a new employee. They're able to login sucessfully once, but after they log out they get this error. They're trying to login from the browser, not a 3rd party app or anything. It only happens if they're using Chrome, if they use Firefox then they're able to login just fine.

The only app we have which uses OAuth is Cirrus Insight, I thought it might be something to do with it, but disabling/uninstalling it from Chrome and revoking it did not help. The user is configured idenitically to others. I made a test user on my computer with the affected user's settings and had no issues. I have a feeling there is some kind of issue happening w/ Chrome and Salesforce, I just have no idea what. Any help is appreciated.
Louisa BarrettLouisa Barrett
We are having the same or simiar issue. Users that have always logged on fine are now seeing  'oauth_approval_error_generic' when trying to log on. This has happened to a couple of users using Chrome, other users using Chrome have had no issues. Using a different browser seems to do the trick i.e. Internet Explorer or just keep trying and eventually you can log in. Is this something that has been accidently introduced in Spring 17?
Christian LoewChristian Loew

Not sure if this will help the rest of oyu but I had this same issue suddenly happen to me.  Internally we're developing our new software platform with OAuth authentication as well and what i realized is that there seemed to be some conflict between my login to THAT application and SalesForce (TrailHead).

 

I fully logged out of our new internal application and then was able to log into TrailHead no problem.

 

So, see if you or your users are logging into another OAuth related application, or make sure they are FULLY logged out before attempting their login again.

This was selected as the best answer
Tim WilkinsonTim Wilkinson
@Christian Loew's answer fixed my issue! 
Carlos SiqueiraCarlos Siqueira
I am having the same issue on my DEV org for over a month now. 

User-added image

Once I refresh the browser (Chrome) the error vanishes. I cleared the cache and this only happens at home.
If I tried to login using the same laptop at other locations like Panera or Starbucks, I have no issues.
This error happens when I am at my DEV org and trying to go to the Success Community or Trailhead.
This is my setup and I even tried to "install" whatever is behind the button shown

User-added image