Assignment rules for web to case not working - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Trine RønningTrine Rønning 

Assignment rules for web to case not working

I have an active assignment rule that says if the case origin is web, Chat, Walk-in, Phone or Email, then the case should go to a queue called SPOC 1. line

I have made the "use active assignment rule" check box default.

I cant get it to assign to this queue, it always goes to default owner
Help?
Best Answer chosen by Bhavin (salesforce.com) 
Venkatesh BudiVenkatesh Budi
Here is the Known Issue - SCHEDULED - WINTER '21
https://success.salesforce.com/issues_view?id=a1p3A000000JWhVQAW

All Answers

Trine RønningTrine Rønning
The assignment works when I create a case manually, but when a customer send an offline chat form, the assignment rule dont kick in, and the owner is the default owner and not the queue
sakshi nagpalsakshi nagpal
Possible issues could be
1.  Go to Setup | Customize | Cases | Assignment Rules, look at your assignment rule, and make sure Active is checked on.
2.  When you create the case, make sure the "Assign using active assignment rules" box is checked at the bottom.  You can turn this checkbox on by default by setting it in the page layout, Setup | Customize | Cases | Page Layouts, edit the page layout, and click the Layout Properties button.
Trine RønningTrine Rønning
Sakshi

I have done all this, but still the cases that comes from chat is not assigned right
 
Wendy SchumanWendy Schuman
Trine - did you ever figure this out? I am having the same issue.
Peter KaszasPeter Kaszas
Same here...
Venkatesh BudiVenkatesh Budi
Here is the Known Issue - SCHEDULED - WINTER '21
https://success.salesforce.com/issues_view?id=a1p3A000000JWhVQAW
This was selected as the best answer
Chris DuncanChris Duncan
Thank you @Venkatesh Budi.
sakshi nagpalsakshi nagpal
Hi All,
 For these type of case where owner is system. You can try using trigger to invoke case assignment rules functionality-:
https://developer.salesforce.com/forums/?id=906F00000008z0EIAQ

 Thanks,
Sakshi
Shri VagicherlaShri Vagicherla
Hi, 
We have run into the same issue for Email-to-Case records. (Mainly for Offline Support Chat as well). I built a process builder to assign the case which replicates the case assignment rules for the channels where it is isn't working currently. 
best, 
adi
 
Daria JaśnikowskaDaria Jaśnikowska
Hi @Adi Vagicherla, please could you share how did you build the prcess builder for it?
Daria JaśnikowskaDaria Jaśnikowska
Ok, I already resolved it, if someone interested:

User-added image

 
Shri VagicherlaShri Vagicherla
@daria I saw that you've resolved it. Also, in the process builder, the OWNER ID field will have the Queue ID and not the name. Please let me know if your process is working or not. Also, if you need any help. thanks
Daria JaśnikowskaDaria Jaśnikowska
Hi Adi, it is working with name as well :) Thank you!