Global search is not able to find records - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Buvanachandran SingaravelaneBuvanachandran Singaravelane 

Global search is not able to find records

Dear All,

I am system administrator and I have uploaded few accounts. These accounts are not been able to search by certain user who are not admin.

I checked the settings and the profile has been given read ,write, edit and view all access still they are unable to find.  Please help me with these.
Jackie DoanJackie Doan
Hi Niha,

Are your accounts sharing settings set to Private? If so, a user would only be able to see them if they have the 'view all data' permission, or if an account was explicitly shared with them via sharing rule or manual sharing. 
Buvanachandran SingaravelaneBuvanachandran Singaravelane
How to check that, can you tell me . As far as I know it is not private.
Jackie DoanJackie Doan
Go to Setup, then 'Sharing Settings'. Check your settings for accounts. 

User-added image
Buvanachandran SingaravelaneBuvanachandran Singaravelane
I checked its Public Read/write, still users are not able to see
Jackie DoanJackie Doan
Is it just in search, or when they try to directly access the record as well?
 
Buvanachandran SingaravelaneBuvanachandran Singaravelane
Just in global search, in view or using SF id , users are bale to access the record.
Naval SharmaNaval Sharma
Niha,

Global Search determines which objects to display in the initial search based on the Users object access history. When you create a new object, there is no history so the object is not displayed in the initial search page. When you hit the 'Search All' button, you'll see the records you expect.

If you want to always include a certain object in your initial search results, pin the object on the left column of the search results page.  This tells Global Search to include this objects in its search.

You can also look at the salesforce article  - http://help.salesforce.com/HTViewSolution?id=000176816
Buvanachandran SingaravelaneBuvanachandran Singaravelane
Hello Naval,

I am using default object for search which is account, that too using only account name. Still it is unable to find. I checked the document but no solution works for me.

 
Martin KeatingMartin Keating
Naval,

Try this, maybe it is the issue. Sometimes the simple things can cause headaches.

After our search...
User-added image

Now we have:
User-added image
Buvanachandran SingaravelaneBuvanachandran Singaravelane
Dear Martin,

I tried it but still not working.:(
Martin KeatingMartin Keating
What license and profile are assigned to the users?
M Sai kumarM Sai kumar
You might have this filter near search. So click on this options link and uncheck those two checkboxes and save & Search. It will work.
User-added imageUser-added image
Richard DiNardoRichard DiNardo
Just happened here. used global search to search for part number three times. First normal then search all. No results found. Went to the object looked at record went to global search. No results found. Then search all found the record. Went on to another record and back to search and no results found for either normal or search all for a part it just found????