Trailhead Challenge issue - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Sara ConnorSara Connor 

Trailhead Challenge issue

Hello,

I am working on the challenge "Get Hands-On with Group Permission Sets" for "Administrator Certification Maintenance (Spring '20)"

Here is the challenge: 

Bundle the permissions for your Sales Ops Team.
Create a permission set for Cases
Permission Set Name: Case Read Only
Case Object Permission: Read Only
Fields (Read Only):
Account Name
Case Reason
Description
Create a permission set for Leads
Permission Set Name: Manage Leads
Lead Object Permission: Edit
App Permissions:
Convert Leads
Transfer Leads
Create a permission set group: Sales Ops
Group the following permission sets:
Case Read Only
Manage Leads

It's an easy challenge; however, I am getting the error message over and over even after I deleted it and recreataed. I also tried created it in a different playgraond. I believe there is a bug and setup incorrect at the back end. Do anyone have the same issue? How could I get this fix? 

"Challenge not yet complete in My Trailhead Playground 32
We can't find a permission set named Case Read Only."

Attached my screen page here.
User-added image
User-added image
Best Answer chosen by Bhavin (salesforce.com) 
Hesham AlbordiniHesham Albordini
First, you need to create a new trailhead playground to pass. Don't waste your time by using a playground built before the Spring 20 release.  Will not work.  Create a new one. 

Get Hands-On with Group Permission Sets.

Quick find box 
  • permission set ==>New ==>Label:Case Read Only ==> Save
  • Object Settings==>click on Cases==>Edit==>ObjectPermissions:check Readonly
  • Field Permissions: Account Name,Case Reason,Description ==> ckeck readonly

Quick find box
  • permission set ==> New ==> Label:Manage Leads--Save
  • Object Settings=>click on Leads=> Edit ==>ObjectPermissions:check Edit ==> save
  • App Permissions ==>Edit ==>sales ==>Convert leads,Transfer leads ==>Save

Quick find box
  • Permission Set Groups ==>New Permission Set Group ==>Sales Ops
  • Permission Sets in Group ==> Add Permission Set ==>Case Read Only,Manage Leads ==>add ==>done

All Answers

Kundan Kumar JhaKundan Kumar Jha
Hey,
 Please make sure that you create a group permission set and add both these permission set into these group.
I already just completed.If this help you please mark as best answer.
Thanks!
Kundan Kumar JhaKundan Kumar Jha
Here is the screenshot.Follow the below steps:
 Click Setup->Search Permission set group->Create a group named Sales Ops ->Add both permission set into this group. If this help you, please mark as best answer.
User-added image
Thanks!
Eduardo ReisEduardo Reis
Hello,

I'm got this error too!

Imagem adicionada pelo usuário

Imagem adicionada pelo usuário
孝純 進藤孝純 進藤
Hello, I have same issue. We can't find a permission set named Case Read Only display even this permission already created in my playground.
 
孝純 進藤孝純 進藤
PermissionSets Case Read Only
Even Permission Sets Case Read Only exist in my Playground, same error occur [We can't find a permission set named Case Read Only]. Is this salesforce bug or am I missing something in my setting?
Dustin StricklerDustin Strickler
Same issue. -ds
孝純 進藤孝純 進藤
I could able to solve error.
Here is tips.

Issue occur on japanese language Trailhead environment.
https://trailhead.salesforce.com/ja

<How I solved>
But when I have done same hands on on English Trailhead environment,
I could able to pass the hands on.
https://trailhead.salesforce.com/en
<Error reason>
So error occur by trailhead environment language issue.
If anyone has same error issue, try to do same hands on with 
https://trailhead.salesforce.com/en/content/learn/modules/administrator-certification-maintenance-spring-20/get-handson-with-permission-set-groups

Best Regards,
Olivier BRICQUIROlivier BRICQUIR
Thanks 孝純 進藤. Indeed, it worked by changing the trailhead language.
Shirish AshwatShirish Ashwat
Follow the instructions and it works - not complex. Create 2 different permission sets (Case Read Only, Manage Leads) and the give the required Object Permissions & App permissions. Later create the Permission set group (Sales Ops)  and add the permissions sets you created in the first step and you are done.
Lakhan MeghaniLakhan Meghani
hey
Please check launch the playground again and check the check the challenge
Also check prefix or suffix space in the permission sets names.
Otherwise do the challenge in different playground.
Thanks
Rachana RajshekarRachana Rajshekar
Hey 

I can't find the 'Permission set groups' in quick find. I tried in developer edition. Is anyone aware how to enable that option?
Olivier BRICQUIROlivier BRICQUIR
Hi Rachana,

I faced the same issue with the "Official Playground" and my personal dev. However I've been able to search for the "Permissionn set groups" using a Trailhead Playground I created myself. (Using the button "Create a Trailhead Playground") 

Hope this helps.

Cheers
Venkatesh AlagarsamyVenkatesh Alagarsamy
Hi Team,
               Ensure the following configuration enabled as below.

                1. Session Activation Required option is Enabled.
User-added image
2. License Option is  --None--
User-added image
3. Permission Set Group Will be displayed as belowUser-added image
4. Go to the Trailhead and click the Check Challenge Option. Now you will be able to complete the challenges
                
Sara ConnorSara Connor
Thanks everyone for the ideas! I beleive that is a bug in the playground for some of us! I actually created 3 different playgrounds and still getting the same error before I posted my issue on the community.I was getting the same error in each different playground that were all set to English language setting.
Inspired by 孝純 進藤 method, . I changed the first language listed below English- in the playground and I passed. Woohoo!! 
Hope this help the ones encountered the same issues as I did.
Mary Ann SteinbrennerMary Ann Steinbrenner
Ok, I am getting the same error as well and I have the permission set set up correctly.  I've spent almost 2 hours trying to figure this out when it should have only been 10 minutes.  So frustrating!
Mary Ann SteinbrennerMary Ann Steinbrenner
I cleared my history and I was finally able to pass the exam.
Anvesh ThakkallapallyAnvesh Thakkallapally
Thanks 孝純 進藤. It worked !
Steven ChenSteven Chen
Hi Team , Got the same issue even in English envirnment. But Try this, It worked for me:
1. Make sure those permission sets are in place in playground 
2. refresh the trailhead page on computer, then make sure to select the correct org and 'Check Challenge to Earn 500 Points'
Mansi KatariaMansi Kataria
Hi All, I am getting the same issue, I am unable to find the permission sets group both in my dev instance as well as the playground instance when I try to find through quick find. When I try to create new playground instance, I am getting error. Was anyone able to solve for this? 
Rachana RajshekarRachana Rajshekar
Hi Mansi,

You won't get that option in the developer org or existing trailhead instances.Create a new trailhead playground and you will find the option there. It takes some time for the option to be visible.
 You can create a trailhead playground by choosing 'create a Trailhead Playground' from the dropdown.
Tyler MoodyTyler Moody
Hi All,

I am running into the issue of not having the option of Permission Set Groups in setup, when I created a new Playground I'm being asked to login with username and password, obvioulsy I don't have that, how I can login to the new Playground to see if I can access Permission Set Groups?
Alia BurdickAlia Burdick
I am having the same issue as Rachana and Tyler. Tried to complete the challenge in an existing dev org - but the permission set groups option wasn't visible in Setup. I created a new trailhead developer org to try and do it there, but when I try to launch it from the trailhead module I am being met with a login screen instead of being automatically logged in. Will wait a while and see if that resolves the issue. 
Alia BurdickAlia Burdick
Just a heads up - I created another new playground for trailhead (the first one still asks me to log in) and the second one launched just fine, and I do see permission set groups there now. So maybe those having the same issue can try that and see if it resolves.
Mansi KatariaMansi Kataria
Thanks all! It finally worked after trying multiple times. I had to create a new playgorund but for that also it took me multiple tries and it worked. 
Ma Jurnalyn BommadevaraMa Jurnalyn Bommadevara
Just try and try new trailhead playground until then eventually permission set group will show up ( my experience ). I guess some bugs need to be fix.
Just passed the challenge.
Hesham AlbordiniHesham Albordini
First, you need to create a new trailhead playground to pass. Don't waste your time by using a playground built before the Spring 20 release.  Will not work.  Create a new one. 

Get Hands-On with Group Permission Sets.

Quick find box 
  • permission set ==>New ==>Label:Case Read Only ==> Save
  • Object Settings==>click on Cases==>Edit==>ObjectPermissions:check Readonly
  • Field Permissions: Account Name,Case Reason,Description ==> ckeck readonly

Quick find box
  • permission set ==> New ==> Label:Manage Leads--Save
  • Object Settings=>click on Leads=> Edit ==>ObjectPermissions:check Edit ==> save
  • App Permissions ==>Edit ==>sales ==>Convert leads,Transfer leads ==>Save

Quick find box
  • Permission Set Groups ==>New Permission Set Group ==>Sales Ops
  • Permission Sets in Group ==> Add Permission Set ==>Case Read Only,Manage Leads ==>add ==>done
This was selected as the best answer
Anand ShindeAnand Shinde
Hi All,

I faced simiar issue. I refreshed page after error message,selcted correct playground and checked for points. It worked for me !
athar ahmedathar ahmed
Hi All,
If you are facing an issue of not being able to find 'Permission Set Group' in your org or on your existing playground. To resolve this issue, you can create a new trailhead playground and on that playground you can have the option of  'Permission Set Group'. Just refresh 3-4 times if you are facing an issue of getting into the newly created trailhead playground. Then you can complete the task. 
Thanks
Ameerunnisa SyedaAmeerunnisa Syeda
Thank you Hesham Albordini! It worked in a Salesforce classic old playground as well.
Tagui GotohTagui Gotoh
As a Japanese user, it worked out with 孝純 進藤's method posted on April 20.

Either Trailhead Playground and module itself, I have changed language to English, and it's fine.
This may apply to all non-English Trailblazers.

進藤さんありがとうございました!
 
Rogerio Borges GriloRogerio Borges Grilo
I had the same issue. Clearing the cache & cookies on Google Chrome resolved the issue for me
Rahul MenonRahul Menon
I just refreshed the trailhead page, selected the correct playground from the dropdown and then clicked the "Check Challenge" button and it worked!! I recommend you try that
Jyoti ArusiaJyoti Arusia
Got the same issue. Refreshed the Trailhead module page and clicked the "Check Challenge" button. Voilla..!! done :)
Sarah Dita Julia COHENSarah Dita Julia COHEN
I do not have access to permission set group as you can see :) 
User-added image

what should I do to have access ? 
 
Deepak karanDeepak karan
Create a new play gound again
also clear cookies in the browser that should work !!
Sarah Dita Julia COHENSarah Dita Julia COHEN
@deepak karan, still not see the new feature after create a new playground and refresh cookies... 
so wird 
Do you know what should do else ? 
Ameerunnisa SyedaAmeerunnisa Syeda
@sarah dita try to open the page in different browser like internet explorer in case if you are using google chrome. I have experienced  issues in lightening so I have used salesforce classic and it worked for me. 
Sarah Dita Julia COHENSarah Dita Julia COHEN
@Ameerunnisa Syeda, i am using chrome as well. I ve tried it in classic / lightning and the new feature is not appearing in my sandbox, which is a new one. 
Moreover, i have some Security Alerts appearing on my setup. I really need to validate this module on Trailhead to maitain my certification
Sarah Dita Julia COHENSarah Dita Julia COHEN
still not working with internet explorer. 
Do you know whom I can contact from Salesforce to fix this issue
Ameerunnisa SyedaAmeerunnisa Syeda
 To submit a support case you can follow this link https://help.salesforce.com/articleView?id=workcom_contact_support.htm&type=5
Jyoti ArusiaJyoti Arusia
Unscribe Thanks and Regards, Jyoti Arusia CRM Consultant 9873334145
Shirish AshwatShirish Ashwat
Delete your current permission sets - Empty your recycle bin - login to your trailhead org again . Create the permission sets and refresh again before verifying your task.
Shauna BurnesShauna Burnes
I had to refresh page and it worked finally. 
Martín VilariñoMartín Vilariño
Hello! I experienced the same issue until I selected "Salesforce" for the License for each permission set. Then it passed! 
UTKARSH MISHRAUTKARSH MISHRA
There are mainly 2 problems encountered while completing this task in the English language version.

1st - Permission set groups was not visible in the new /old playground.
Soln - Create a new playground (there is no other option for this), and firstly check if Permission set groups available.

2nd - Case read Only, permission set not found an error
Soln - Clear your Browsing History and there refresh the page and again launch to check the result.
Jeff TelijeuneJeff Telijeune
Hi Folks! I was able to complete it using one tip:
I launched the playground again, switched to Salesforce Classic, then refresh the page while on Salesforce classic, and double-check the challenge. I hope this helps!
Asif KutagullaAsif Kutagulla
Hi All -
I had configured all the steps as per the challenge but it still showed the error as :
Challenge not complete. Case Object Permission Read Only - SUCCESS.
After that i just had to refresh the Trailhead page & then it showed as Assessment complete and with full points.
I didn't have to set language to English or switch to Classic.
Hope this helps.

Cheers.
Jonathan ChimnerJonathan Chimner
I had the same issue. Cleared cookies and cache and tried again and it passed (using Chrome).
Amy M.Amy M.
Can anyone help me, i tried all the steps that i read from this thread and everything, created a new trailhead playground(2X), dev sandbox but still the same issue.Switch from lightning to classic same error. Field permissions - Account name is still greyed out. Spent so much hours but still same error i should try another day again, hopefully it will work. Thanks in advance!
User-added image
Maulik DesaiMaulik Desai
Hi All,
I was facing the same issue but then I deleted the cache and cookies from google chrome browser by going to browser settings. This may log you out of trailhead so log in again and check the challenge. You should be able to pass through the challenge. 
User-added image

Please mark this as best answer if it helps.

Thanks and Regards,
Maulik Desai
Joshua HarrisonJoshua Harrison

@Amy M. you are on the account object and you need to be on the case object.

I was getting the error that it could not find my permission set as screenshotted above.  I have multiple orgs connected to my account and created a brand new one for this.  For some reason it was trying to check one of my other orgs and not the one I launched.  I just hit refresh on the launcher tab and it showed the incorrect org in the drop down, changed it to the correct one and was able to complete.

Amy M.Amy M.
Thanks @Joshua Harrison, it works went to change on the case object and passed.
Mandip ChanaMandip Chana
Hi All,

I've finally got it to work....

Obviously, be 100% sure that you have followed the instructions carefully, including setting up a new Playground. I did, and it would not work until I simply refreshed the Trailhead page, as others have also said on this thread. No need to delete history, or cookies. 

So, once the challenge is complete in your new Playground, go back to the Trailhead page, and refresh it. If it isn't already selected, select your new Playground from the list, and check challenge.

This is what worked for me
ganesh kandulaganesh kandula

Hi All,
Some reason my Trailhead not showing "Permission set group" . Please help me to solve the problem. Thanks..

Permission Set Group

Marisa SkeltonMarisa Skelton
Yes!  I had the same issue.  Refresh the Trailhead page and log back into the playground.  Then it should work.
ganesh kandulaganesh kandula
Yes, I have created new Playground and it worked fine. Thank you.
Ed IvanovEd Ivanov
Hey Guys, I ran into a similar issue. What worked for me was...
1.) New Playground
2.) Checked Session activation for permission sets.
3). After making changes refreshed Trailhead page.
I was stuck on this for a while and was finally able to get it! Good luck!
Rikki JollyRikki Jolly
Hi all,
I have successfully done this challange. Please go with the instructions and I belive this will work for you.

Step 1-: Search Permission set in the Quick Find Box.
Step 2 -: Create two Permission set with the name-:
a)  Case Read Only
b)  Manage Leads
Step 3
-: Search Permission set Group in the Quick Find Box
Step 2-: First you have to create Permission set group with name Sales Ops.
Step 5
-:  Click on Sales Ops and  Click on Open Permission set group.User-added image
Step 6-: Click on Add Permission Set Button. then select the both check box and click on addUser-added image

Step 7-: Here you will see the attached image and Click on Case Read Only.
User-added image
Step 8
-: After Click on Case Read Only you will see the Object Settings link you can click on this and
Choose Case object from here and click on Edit Button and follow this -:
Case Object Permission: Read Only
Fields (Read Only):  Account Name
                                 Case Reason
                                 Description


Follow Step 8 with the Next one Pemission set name Manage Leads. and choose Lead object from here and Click on Edit button then give
Lead Object Permission: Edit

Step 9-: Click on Muting Permission Set in Group Link. click new button this will take name automatically save it.
Step 10-: And Then Click On App Permissions link and Click on Edit User-added image
and  Press Ctrl+F seach Convert Leads and Transfer Leads (Check the both box)
Step 11:- Greate Now you Will click on Check Challange button and See You Have Completed Your Challange :)

Thanks & Regards,
​​​​​​​Monika SIngh
Sundeepta AchantaSundeepta Achanta
Thanks to everyone who posted answers but unfortunately nothing worked for me. As I tried clearing my cache, logging in an incognito window, refreshing the page, creating new playground. As a last resort I ended up creating a support ticket, in response to which (they responded in just about a day which was much faster than I anticipated!), looks like they recreated my playground wiping it clean, (i did have to re-do it) but that was much quiccker compared to troubleshooting it and this time it worked!

Hope this path helps someone!
Akshay MudgalaAkshay Mudgala
Hi Everyone

There seems to be an issue when we try the challenge in a new playground. I faced the same error when I tried this challenge in a newly created playground.

Later I tried in my own developer org and completed successfully.

Thank you.
William KreugerWilliam Kreuger
Hey, I was facing the same issue and then I just closed playground, switched playgrounds and then switched back to the playground where I configured this and solved the issue. 
Kavthami MuthuramalingamKavthami Muthuramalingam
I was facing the same issue, clearing browsing history helped me to solve the issue. Relaunched the playground and checked the challenge, it worked!

 
Muthukumar RMuthukumar R
I faced the same issue, just refresh the page and submit it again. It would help.
Skylar RhodesSkylar Rhodes
I had to create a new trailhead playground for the permission groups to show. However, my language setting is English and I still recieve "We can't find a permission set named Case Read Only." on the freshly created playground org. 
Skylar RhodesSkylar Rhodes
After disabling my adblockers in Chrome I was able to bypass "We can't find a permission set named Case Read Only"
Rikki JollyRikki Jolly
Step 1-: Search Permission set in the Quick Find Box.
Step 2 -: Create two new Permission set with the name-:
a)  Case Read Only
b)  Manage Leads
Curtis Salesforce AdminCurtis Salesforce Admin
I had the same issue with it saying that it couldn't find theCase Read Only permission set...and my trailhead is already in English.  I think something about the automated checker is buggy.  I got the error twice, but later closed and relaunched the playground and then checked again and this time it worked.
Janet MichieJanet Michie
I changed browser to firefox from Chrome and boom - successs. 
Madhav GoyalMadhav Goyal
I have tried everything, in my dev org, created new playground org, changed langauge.. Nothing worked. Was not able to add Permission Set to Permission Set Group.

Thankyou @Janet Michie, I just switched to Firefox and it all worked.
Rebecca BozkurtRebecca Bozkurt
I worked on this simple challenge for more than 2 hours. When I read the challenge, first I thought it will take just 10 minutes but I kept deleting and recreating permission sets a couple of times until I read someone "clear the History" then clear the history and I was able to complete this challenge. Thank for help. Sometimes it is not about your work, i is the browser. 
Piya FiedlerPiya Fiedler
I had created a new playground as instructions said but was still getting the error OP mentioned. So I closed the playground then refreshed the Trailhead module, re-chose the correct playground, then clicked Launch. Then I went back to Trailhead and clicked Check challenge, and it finally worked.
Shawn ClementShawn Clement
User-added image

I am runnning into the same issue. There is no edit button when I go into the object settings. What should I do to solve this. 
Maya ChoudhuryMaya Choudhury
Creating a new Trailhead Playground helped. After that, simultaneosly creating the new permission sets, "Case Read Only" and "Manage Leads" with the relevant object and app permissions. And as a final step, grouping these  under the "Sales Ops" Permission Set Group. Hope this helps! 
Tommie ThompsonTommie Thompson
Frustrating error - clearing Chrome browser history was the key for me!  Thanks everyone!
Sarah VacchianoSarah Vacchiano
Answer
Created the new playground, followed the instructions. Got the error. Can't find Case Read Only error. 
BUT somehow it reverted back to a previous playground. 
Launched the correct playground and it worked. 
Matt EdenMatt Eden
Anyone still having issues with this: @Steven Chen response was the correct solution.  If you are sure you have created the components correctly but are still receiving the error when you check your org, refresh the Trailhead page and make sure the correct Playground is selected.  I believe this is caused by creating a new Playground from the dropdown on the Trailhead page - it still checks the one you had selected previously.