Superbadge Process Automation Specialist - Challenge 1 - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Kanika SharmaKanika Sharma 

Superbadge Process Automation Specialist - Challenge 1

Hi All,

I have created validation rule, queue and lead assignment rule, but I am still getting the below error.

ERROR
Challenge Not yet complete... here's what's wrong: 
A new Lead with the Source 'Web' was not correctly assigned to the 'Rainbow Sales' queue.

Lead Assignment Rule
User-added image

Validation Rule
User-added image

Can someone help me understand the issue. 

 
Best Answer chosen by Kanika Sharma
Amnon KruviAmnon Kruvi
Hi Kanika,

Are you sure your queue is named correctly? Yours is called "Rainbow Sales Queue", but the error message is looking for a queue named "Rainbow Sales".

All Answers

Amnon KruviAmnon Kruvi
Hi Kanika,

Are you sure your queue is named correctly? Yours is called "Rainbow Sales Queue", but the error message is looking for a queue named "Rainbow Sales".
This was selected as the best answer
Harsh PatelHarsh Patel
Hi Kanika ,
Change your queue name from "Rainbow Sales Queue" to "Rainbow Sales"and check.Also have a look at this solution :https://trailheadbaby.blogspot.com/2017/09/process-automation-specialist.html
Thanks.
Kanika SharmaKanika Sharma
Thanks Amnon, That was clearly a very silly mistake. Thanks for your quick response. I have cleared the challenge.
Marco GonzalezMarco Gonzalez
For anyone else that has this issue, I also had my queue named incorrectly, but still had problems after fixing it.  I was noticing that no Assign using active assignment rule checkbox was present when I edited a Lead.  I had gone into the page layout and tried enabling as the default and it still did not work or show the checkbox.  It started working after I created the User specified in the Superbadge instructions and logged in as that user. I began to see the checkbox and the assignment began to work and I was able to pass the challenge.  So, this may have had to do with my browser cache, and the fact that I had been logging into many different Trailhead Playgrounds. 
Justin HoJustin Ho
I also encountered this error even though my queue name was correct and the lead assignment rule was set up properly.

I think because I was using the Standard assignment rule that was already there instead of creating a new one for the challenge was the problem. I fixed this by deactivating the lead assignment rule then reactivating it.

Or alternatively, I suggest creating a new lead assignment rule and not editing the existing Standard one.
Rahul GawaleRahul Gawale
Thanks Justin creating a new assignment rule with the name 'Lead Assignment Rule' instead of 'Standard' fixed my problem
Mykhailo SavchenkoMykhailo Savchenko
Thanks Justin, it helps me too.
Pedro PradaPedro Prada
User-added imageHi I am getting the following error....

Challenge Not yet complete... here's what's wrong:
A new Lead with the Source 'Purchased List' was not correctly assigned to the 'Assembly System Sales' queue.

Any help would be appreciated
Susmitha GuthaSusmitha Gutha

Hi Padra,

Can you please check the Queue name, I see there is an Extra "." after the Queue name in the screenshot you have posted. Can you try removing the dot from the Queue name. I know this is very minute but worked for me. Let me know if you are able to resolve?

Chris TouegChris Toueg
Just experienced this same issue myself. Both queues were named correctly, Lead Assignment Rules (I was simply using the 'Standard" rule) were configured correctly, but the Challenge Check just did not want to accept it.

What finally worked for me was deactivating the Lead Assignment rule, running the Challenge Check again (which would predictably fail), then activating the Lead Assignment rule and running the Challenge Check one last time. That time it was accepted and I was able to move on to the next step.

Hope this helps!
MPB SalesforceMPB Salesforce
Hello All if you have any query about this challenge so please watch
https://www.youtube.com/watch?v=fenHKe9EfNw&list=PLQf_Kv-dMRBJNdXFH44hPImsHY47yaG12&index=6

it's very helpful video series
Neha LabhNeha Labh
I am stuck at challenge 1. I have made 2 queues and named them correctly. still I am getting error that Challenge Not yet complete... here's what's wrong:
Could not find two queue for Leads

User-added image
please help
Jithin ChandJithin Chand
Neha,

I think you are using the standard lead assignment rule and added your condition to it. For some reason this does not work. I am not sure why. If you are using a new lead assignment rule, then i am not sure, probably you need to provide more details.


Regards
Jithin