I'm not receiving my scheduled reports - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Brad DavidBrad David 

I'm not receiving my scheduled reports

Good morning salesforce community!  I'm very new to salesforce and am not getting my scheduled reports via email.  I've tried multiple different times (just incase it's a time zone issue) and confirmed that I am receiving the test emails.  I'm sure it's something simple, but I can't seem to find out why. 

Appreciate the help!
Best Answer chosen by Brad David
Michelle ArndtMichelle Arndt
There are several things you can check to see what is happening with your scheduled reports.
1. Confirm that the schedule didn't expire - you said you already did that so we can cross that over.
2. Look in Setup > Monitor > Jobs > Scheduled Jobs to see if the report is scheduled to run again - that way you can confirm that system is working and that there are no problems with schedule.
3. Go to Setup > Monitor > Logs > Email Log Files and request an email log file for the day the report was supposed to be emailed, and the to/from user it was to be sent to. When the email log is ready, download it and unzip it. Then sort the report by Date Time and look around the time when the report was supposed to be sent. If it's in there, then your report was sent (or was attempted to be sent), but might have gotten hung up by your email server. If there was trouble sending, you'll see a number the "Retry" column.
4. Make sure that report didn't end up in Spam folder or that you don't have any Outlook rules that might re-direct email with report to other folders or emails. I
5. If all the above is working and you still don't see the reports being delivered to you, check with your IT team - email servers sometimes mark scheduled Salesforce reports as spam so they never gets delivered to user's inbox.

All Answers

Michelle ArndtMichelle Arndt
There are several things you can check to see what is happening with your scheduled reports.
1. Confirm that the schedule didn't expire - you said you already did that so we can cross that over.
2. Look in Setup > Monitor > Jobs > Scheduled Jobs to see if the report is scheduled to run again - that way you can confirm that system is working and that there are no problems with schedule.
3. Go to Setup > Monitor > Logs > Email Log Files and request an email log file for the day the report was supposed to be emailed, and the to/from user it was to be sent to. When the email log is ready, download it and unzip it. Then sort the report by Date Time and look around the time when the report was supposed to be sent. If it's in there, then your report was sent (or was attempted to be sent), but might have gotten hung up by your email server. If there was trouble sending, you'll see a number the "Retry" column.
4. Make sure that report didn't end up in Spam folder or that you don't have any Outlook rules that might re-direct email with report to other folders or emails. I
5. If all the above is working and you still don't see the reports being delivered to you, check with your IT team - email servers sometimes mark scheduled Salesforce reports as spam so they never gets delivered to user's inbox.
This was selected as the best answer
Brad DavidBrad David
Thanks Michelle,
It appears as though my IT had them being blocked as Spam... I'm working through unblocking them now.  Your 1-4 steps were very helpful as well.  I appreciate the help!
Brad
Michelle ArndtMichelle Arndt
Glad you got it figured out!