Reset Security Token does not appear (Admin Role) - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Bob WhiteBob White 

Reset Security Token does not appear (Admin Role)

We have a third party app that is requesting a security token, however, I can not access reseting the token.  Other roles in our org have aceess to this, but the admin role can not access this on there login?  I've had a token issued before (year or more ago), but I can't get one now?  Is this a bug?
Best Answer chosen by Moderator (salesforce.com) 
Dan WoodingDan Wooding
Do you have IP restrictions on the Profile? Meaning that users of the profile can only login from certian IP ranges? That is the most common reason i've seen on why the reset is no longer visible. 

Do you use Single Sign On? With SSO a security token is not used so it would not be avaialble.

Try the first and let us know.

All Answers

Chris O DaviesChris O Davies
Here is a link on how to reset security token:
https://na7.salesforce.com/help/doc/en/user_security_token.htm
Bob WhiteBob White
The reset security token does not appear.  This problem seems to tie to the Admin role/profile?
Chris O DaviesChris O Davies
Have a look at the profile does it have API Enabled set to false?
Bob WhiteBob White
API Enabled is set to True in the profile
Dan WoodingDan Wooding
Do you have IP restrictions on the Profile? Meaning that users of the profile can only login from certian IP ranges? That is the most common reason i've seen on why the reset is no longer visible. 

Do you use Single Sign On? With SSO a security token is not used so it would not be avaialble.

Try the first and let us know.
This was selected as the best answer
Bob WhiteBob White
No IP range restrictions, Not using single sign on.  Every other user in the org has this visible - two with Admin role do not.  I access othe rthird party add-ins with no problem.  I had a token issues more then a year ago.  Must be some setting somewhere, or its a bug?
Bob WhiteBob White
After another review, it was associated with the IP Range settings. At first, it appeared the range was set wide open, but the fact it had any range at all was causing the reset tokens not to show.
Josh AbshireJosh Abshire
We've ran into this issue before as well.  We use some integrations that require a security token.  However, we have trusted IP ranges enabled.  When you have those enabled, you won't see the reset token link if you're logged in from an address in a trusted range.  To get around this, we use the below URL:

https://[SalesforceDomainHere]/_ui/system/security/ResetApiTokenEdit?retURL=%2Fui%2Fsetup%2FSetup%3Fsetupid%3DPersonalInfo&setupid=ResetApiToken

Just make sure that you're logged in as the user you want to reset.  This URL has been a lifesaver for us.

Take Care,
Josh
Puneet MishraPuneet Mishra
Its just url hack but I must say "Genius" 
Travis OliverTravis Oliver
@josh abshire Thank you so much! That link just saved me a bunch of time.
Peter BurgessPeter Burgess
@Josh Abshire - you are an absolute legend.  I've spent days trying to get Force.com connected. Chasing my tail.  Not sure whether the problem is wrong server, missing token, or why i could not reset the token.  I had worked through docs on why the link may be missing, still nothing.  Your URL is all i needed.  Why hide this link Salesforce?  Why make this so hard for so many people for so many years?
Neel Kamal SinghNeel Kamal Singh
@Josh Abshire - Simply Genius
Ray ChengRay Cheng
For us, it's found at Admin > My Settings > Personal > Reset My Security Token
Francois KorbFrancois Korb
Thank you for sharing the URL remedy - worked like a charm.
Charles van der WalCharles van der Wal

Trying to use the URL hack mentioned above, but no luck sadly. When integrating with a third party app and resetting the security token (via method mentioned above); it will simply not connect. The third party application is unable to connect to Salesforce.

 

I havent found any other way of connecting Salesforce to a third party app, using a trusted IP range. Anyone have any other suggestions perhaps?

Regards,

Charles

Yadnesh KuvalekarYadnesh Kuvalekar
@Josh Abshire, your simply great and genius. It helped me to Reset Security Token.
Carlos ValleCarlos Valle
@Josh Abshire, you saved my life...
Jobin ThomasJobin Thomas
@Josh Abshire, thanks
Pierre DesjardinsPierre Desjardins
Amazing that a hack from 2+ years ago still works! Thank you @Josh Abshire!
Cesar PeresCesar Peres
Thanks @Josh Abshire, after a few hours of search, you saved my life!!!
Avinta ServicesAvinta Services

@Josh Abshire - seriously..........genius! I'm taking you to Disneyworld!

Carlos SiqueiraCarlos Siqueira
I have a DE org that I had to change the password and got a new token, but can't figure out where to use it.
Since this is a DE org just used to get the Wave badge, there is no IP ranges. When I try to login using the new password, it does not let me. What should I use as my [SalesforceDomainHere] ??
This is what I see at home:

https://na35.salesforce.com/home/home.jsp

Anyway that I can disable this requirement?
Thanks
Donovan EtchisonDonovan Etchison
@Josh Abshire Three years later and your answer is a life saver. We have SSO enabled so the Reset Security Token option does not appear. Your link worked like a charm. Thank you!
Trinetra RawlsTrinetra Rawls
@Josh Abshire Came across the same issue today. We have SSO enabled as well. Not only did the link work, it was a life saver for an urgent request. Thank you! Thank you!
PN RudraPN Rudra
@Josh Abshire - Time saver! Thank you!
shailendra singhaishailendra singhai
@josh abshire- Thanks for the help 
Amber HasanAmber Hasan
  1. Go to developer.salesforce.com (https://developer.salesforce.com/)
  2. Click My Developer Account under your name in the top right.
  3. Log in
  4. Click on your name again at the top and choose My Settings
  5. Expand the Personal menu on the left side
  6. Click “Reset My Security Token”
Ogaga UmukoroOgaga Umukoro
Thank you! @Josh Abshire .. I'd searched for so long and couldn't find help but that link worked! We have SSO enabled but the production environment works with the reset token in my profile and I'm an admin. The full copy sandbox didn't work at all, and it previously did. Thank you once again
Barry FirmanBarry Firman
@Josh Abshire. If I could have upvoted your post 20 times I would have. Thank you!
Sam HowleSam Howle
Thanks @Dan Woodling and @Josh Abshire - removing the IP login range on my System Admin profile was what worked. A blanket range was being used before (0-255) but after removing it I could view the "Reset my Security Token" tab again. Thanks a lot
Bob TeplitskyBob Teplitsky
Thank you @Josh Abshire!
Ogaga UmukoroOgaga Umukoro
I found a solution to this without removing IP range. https://success.salesforce.com/answers?id=90630000000grjhAAA Ogaga Umukoro, DevOps & Security Analyst 1.888.639.8181 | newtopia.com
Sadhiq MohammadSadhiq Mohammad
@Josh Abshire.. Thank you. This Saved me..!!!
zahraa wahshzahraa wahsh
@Ogaga Umukoro
how did you resolve it for the test instance please ?
zahraa wahshzahraa wahsh
it works in the production and in the sandbox. 

but it is not able to connect to the application using the token and the password ? 
Niteesh kumarNiteesh kumar

In Setup Quick Find box not getting option for "Reset My Security Token" tha 

1. go to you - my setting from you Name dropdown in salesforce classic.
2. In left hand site you get option like Reset My Security Token" click on it you will gwt mail on you registered mail Id.

Parikhit SarkarParikhit Sarkar
@Josh Abshire Thanks a lot.. Your answer is a great hack!
Vijaykumar MamidalaVijaykumar Mamidala
I have tried to use force:user:password:generate, It is resetting the password through CLI but unable to send email with new Security token.
I have tried to reset the security token via UI, it was worked fine and received the email.
After resetting first time through UI, then using CLI I can able to get email with security token while resetting the pwd.
this is strange.
any ideas on this?
Mamadou Ramadane DIALLOMamadou Ramadane DIALLO
This youtube video really worked for me!  https://www.youtube.com/watch?v=7GT9qlz_4Vg