Why didn't my dynamic dashboard auto-refresh & send as scheduled? - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Kat AmanoKat Amano 

Why didn't my dynamic dashboard auto-refresh & send as scheduled?

I have a dashboard scheduled to refresh & send to certain users every day at 7:00 pm.

It didn't send last night, so I checked the refresh settings and everything seems fine (the date range extends till the end of this year, so it hasn't expired; and I am the running user, so it's not because the running user is now inactive).

I know the exact send time can vary a bit depending on what's in the queue, but it's now 9:20 am our time, so we'd be talking a 14-hour delay if that were the case. I don't think that's likely, so I was hoping someone else might have had this problem before...

Thanks!
Best Answer chosen by Moderator (salesforce.com) 
Aaron DeRanAaron DeRan
Yes, it SHOULD but I cannot confirm for sure. Best bet is to monitor tonight's and see if that occurs.

The fact that it says it started and the next one is scheduled seems to mean it completed. If tonight's does not start... then Houston, we have a problem.

All Answers

Aaron DeRanAaron DeRan
Have you checked your scheduled jobs?

Click Your Name > Setup > Monitoring > Scheduled Jobs.

Is it still listed?
Kat AmanoKat Amano
Hey phiberoptik,

Thanks for the reply! I just checked where you said, and the weird thing is that is says that it "started" at 2/20/2013 7:01 PM (as it should have), and that the next one is scheduled for 2/21/2013 7:01 PM (as it should later today).

However, when you click through to the actual dashboard, it says it that last refreshed "As of Two days ago at 7:01 PM" -- and that should say "As of yesterday at 7:01 PM," right?
Aaron DeRanAaron DeRan
Yes, it SHOULD but I cannot confirm for sure. Best bet is to monitor tonight's and see if that occurs.

The fact that it says it started and the next one is scheduled seems to mean it completed. If tonight's does not start... then Houston, we have a problem.
This was selected as the best answer
Jared PaulJared Paul
Hi everyone! Please don't forget to mark "BEST ANSWER" to the most helpful solution (below the comment) and feel free to upload a profile pic if you don't have one. Thanks!
Kat AmanoKat Amano
So I never actually changed any settings, but the dashboard has been sending successfully for the last week so it looks like we're ok and that was just a one-time glitch. Weird that I couldn't determine why it was actually happening, but at least it hasn't happened since then. Thanks again for your time and help!
HariKrishna SompalliHariKrishna Sompalli
Here is the work around for this: https://chrome.google.com/webstore/detail/enhance-salesforce-dashbo/mogildlgjglckdcfclpbcbidpdkjgeeb?hl=en

You can add this extesion to your chrome browser and can specify the auto refresh interval along with the number of  charts/reports should display in a row.
Chirag MehtaChirag Mehta
Thanks HariKrisha for the link.  There's AppExchange Listing as well.

https://appexchange.salesforce.com/listingDetail?listingId=a0N30000000q4pAEAQ