Chatter Desktop: It used to work, now it blocks everyone and asks to Authorize?? - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Kyle BoernerKyle Boerner 

Chatter Desktop: It used to work, now it blocks everyone and asks to Authorize??

One of my coworkers reached out to me yesterday about his Chatter Desktop failing to launch upon turning his computer on.

The same thing happened to me today, and Chatter Desktop reads: "Authorize Chatter Desktop.  To access your Chatter data, authorize this application in Salesforce.com.  Cannot access Salesforce.com.  Verify your computer is online.  It offers a drop-down box with Production or Sandbox as options.  Lastly, there is an Authenticate button. 

I went to Internet Options on Internet Explorer and ensured that *.salesforce.com and *.verisign.com were set to allow in Security and Privacy Settings.

What else am I missing and what could be blocking us from running Chatter Desktop?

Thanks for you help,
Kyle
Elizabeth DavidsonElizabeth Davidson
Have you double checked the chatter settings in Setup?  The administrator has to authorize the org to be able to use desktop.  Go under Administration, Desktop Administration, then Chatter Desktop Settings.  The first section of the page has a box that must be checked for it to work.  


Larry FrenchLarry French
Kyle,
 

We were having the same issue even after enabling Chatter under Administration.  We had been previously using Chatter as a free service before using SalesForce as a paid service.  This caused a problem since our user accounts were moved over to Salesforce. 

To solve this issue we performed the following on our Windows 7 Professional workstations:

 1 - Uninstall Chatter Desktop client via the Control Panel -->Programs and Features

2 - Enable hidden files and folders in Windows Explorer

3 - Navigate to C:\Users\'username'\AppData\Local\Adobe --> Delete the Air folder

4 - Navigate to C:\Users\'username'\AppData\Roaming\Adobe --> Delete the Air folder

5 - Reinstall the Chatter Desktop client

*Substitute the 'username' with the name of the currently logged in user

You will then be prompted for a username and password and will be given the opportunity to authorize the client.

The entire issue seems to be cached credentials in the Adobe Air folders.

Michael FordyceMichael Fordyce
I would like to add my tip here for anyone it may apply to:

I lost my net/wifi connection earlier today and internet explorer got set to "Work Offline" and I began experiencing this issue hours later after I rebooted my computer. I rarely use internet explorer so I didnt realize that it was still in offline mode. Finally figured it out and set it to work online and I was then able to log into Chatter. 

--Mikey
Jeffrey CuevaJeffrey Cueva
Have you tried checking your proxy settings? I experienced the same issue and was able to determine that it was a proxy issue
Stjepan PavunaStjepan Pavuna

Thanks to Michael Fordyce for pointing out "Work Offline" problem. I too had a connection issue at some point while my IE was opened, IE got set to work offline. Since i don't use it often, I hadn't opened it recently and it never reset back to "work online".


It seems that Chatter checks that flag before trying to go online. Very bad design imho...

Anyways, after turning IE on, the flag got reset and I was able to connect with my chatter once again...

Sarah KinghamSarah Kingham
I was able to successfully use Larry's solution.  My Chatter somehow got installed on an external drive that was no longer connected.  Adobe AIR couldn't re-install Chatter until the AIR diretories had been deleted.
Thanks, Larry,
Sarah
Cory McCartyCory McCarty
I had this issue on several computers I was using for training purposes. I was able to login using my credentials, but would get the "remote access authorization error" when trying to login with a user account associated with a Chatter Free profile. Larry's solution resolved the issue.
Hope PriceHope Price
@Larry  I did as you said, and it worked.  However, I just had to reboot my computer, because it was being slow, and then had the same problem again with C Desktop.  So I deleted those two Air folders, and was able to log back in.  Am I going to have to delete those folders every time?
Thanks.
Chris CutlipChris Cutlip
i am having this problem today, all of a sudden.  i've been using chatter desktop for months and now i get this error.  i did find this solution and am waiting to get admin rights so i can delete the folder indicated.  hopefully it works.

http://help.salesforce.com/apex/HTViewSolution?id=000041366&language=en_US
Chris CutlipChris Cutlip
I tried the fix outlined above but it still didn't work.  I ended up uninstalling and reinstalling chatter desktop and it is fine now. 
Hope PriceHope Price
I just went through this problem.  The tech said that apparently it is an issue with Adobe Air updates, something they have no control over.  But she gave me a work around, and we'll see how it works from now on.

Here is the solution that she gave:

"Hello Hope,

Thanks for taking my call. Again, my name is Diana and I have taken ownership of your case. The issue that you are having is unable to login to Dafault connection on Chatter Desktop without deleting the ADOBE AIR folder. Here are the steps we took.

On Chatter Desktop, click on Add New Connection
Enter the Connection Name (production)
Enter URL (login.salesforce.com)
Make sure to select this Connection when you access Chatter Desktop
Select Authorize

We are able to login to your Chatter Desktop after doing the steps above without deleting anything. Also the Production Connection as the same environment on your Default Connection. with your permission, I will be closing this case. It was my pleasure assisting you regarding this concern. You may also check Help and Training for future reference.

Thank you for choosing Salesforce."

She also said that if you need to, you can go into settings and revoke user's access, if you need to log them out of another connection.
Bryton PillingBryton Pilling
I had this problem also, and I took the following steps, but some of these are probably not required.:

Reset user password in Salesforce
Opened Chatter Desktop and when the Authorization error appeared clicked "Not You?" and followed the instructions using the new password
Was able to login to Chatter Desktop but had the full web view instead of the Chatter Desktop view.
Closed chatter desktop and then used the task manager to close an instance of Chatter Desktop that was still running in the background.
Had to relogin again
Essie LarsenEssie Larsen
I still have this problem. I have tried all of the solutions above, but am still getting the error message. I also tried uninstalling Chatter & Air, then restarting the computer & reinstalling both programs. Re Hope's comment - I tried this but there is no 'add new connection' button on my chatter desktop.

Does anyone have another suggestion? Appreciate it
Essie LarsenEssie Larsen
Also, to add to the above - IE11 doesn't have a 'work online/offline' option that I can find