Missing fields in Process Builder? - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Peter FranzenPeter Franzen 

Missing fields in Process Builder?

I'm trying to write a very simple process to update a checkbox field on an Account when a contact within that account sets a checkbox to equal TRUE.

However, I only get a very very short list of available Account-level fields when I try to create my action in the Process Builder. Are there limitations to the fields that it can access?

I also tried to create a standalone field update action and use that as the action for the process builder, but it doesn't even come up as an available option when I select a Quick Action.  Again, are there limitations that I am missing?
Best Answer chosen by Peter Franzen
Johan YuJohan Yu
Peter, this is something possible.
Are you set the Account level field correctly?
User-added image

All Answers

Peter FranzenPeter Franzen
I just got off the phone with Support on this.  Apparently Salesforce never bothered to mention anywhere in the documentaiton that you can't update a parent (Account) from a child (Contact) using the Process Builder.  I know this used to be the case with Workflow Rules, but it was my impression that th Process Builder was going to allow this to happen.

What is frustrating though is that some things can be updated from the child to the parent.  I could update the Account's owner, for example.  Or the Record Type ID.  But for some reason I can't update this particular field.
Johan YuJohan Yu
Peter, this is something possible.
Are you set the Account level field correctly?
User-added image
This was selected as the best answer
Peter FranzenPeter Franzen

OH!  Now I get it.  I was trying to get there by choosing "Account ID > ... " but I didn't know that I just needed to choose "Account ID" and then set an object variable.  Apparently Salesforce support didn't know that either.

THANK YOU!

Meredith KleinowMeredith Kleinow
I just had the exact same issue and this worked for me too. Thanks Peter!
Vegard ØsthagenVegard Østhagen
Thank you Peter, I just had the same issue but you solved it for me! :)
John DelaneyJohn Delaney
Just had the same problem and this worked.  Thanks Peter and Johan!
Johan YuJohan Yu
Sometimes we just need to be more patient :)
Nathan ShulmanNathan Shulman
For those of you who scrolled this far because you tried the best answer and STILL don't see any fields... check your field level permissions.  I didn't bring the permissions over in my deployment, so the fields weren't available in process builder until I gave myself permission to read and/or edit them.

After you set the permissions, and because Lightning, close that process builder you were working on, refresh the page, and see if the fields now (finally) show up.
Paul McCollumPaul McCollum
And if that doesn't work... I was trying to find the field that was the "relationship field" between the 2 objects. Seems that's a given and you don't have to specify the relationship join. 
Dane DellaCrosseDane DellaCrosse
The description field is not Comment field is on the Task Page Layout options but not in the process builder. The Comment field is on the Task Page Layout but not in the Process Builder field options. How do I add text to the task?
Erin GilbertErin Gilbert
Thanks for posting this, Peter! I was doing the exact same thing and this really helped me out!