Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Connor SmallConnor Small 
I am trying to add text labels to a dashboard and I cannot find the text widget? is this only available inside the analytics studio.
Best Answer chosen by Connor Small
Rachel FrazerRachel Frazer
As far as I can tell, you can only add text at the component level using the Dashboards tab. You can add a Title, Subtitle and Footer to an individual component.
Add Component Popup
Mark WhittenburgMark Whittenburg 
My Read Receipts display oldest not newest and the Lable always shows 20 new read receipts however those are not new they're old. 
 Recent Read Receipts not displaying
The same number, 20, is always displayed and those are old read receipts.
Best Answer chosen by Jayson (salesforce.com) 
Michael MosbyMichael Mosby
This worked for me:  https://chrome.google.com/webstore/detail/salesforce/jjghhkepijgakdammjldcbnjehfkfmha

Salesforce Inbox is the old plugin....That plugin above works great.  New layout, same functionality.
Christopher DelaneyChristopher Delaney 
Hello Salesforce, 

When I go to run a recipe in einstien analytics sutudios the error I recieve is "Unexpected end of JSON input" this is the first time that I am seeing this error and all of the recipes ran succesfully this morning without triggering that error. 

Any assistiance or words of advice would be greatly appreciated. 

Thank you, 



Best Answer chosen by Christopher Delaney
Sudhakar ViparthiSudhakar Viparthi

Hi Christopher,
Contacted EA team and here is the reason. It is workng fine now for me.

Bug reference number: W-8518145
fix has been released(via eRelease)..

Dan PaulDan Paul 
I've been migrating Einstein assets using change sets (via a tool called flosum) for a while now.  It's been a slow process since we need to upload data into datasest from csv's, create or update dataflows, run them, then migrate dashboards (due to their environment specific ids).  So in general it's been a slow process when repeatedly doing it to fresh environments. 

Has anyone figured out a better way?  
Best Answer chosen by Dan Paul
Prabhat MishraPrabhat Mishra
Hi Dan,

Templated apps looks like a good fit for your case. You can expose the unfixed columns as variables to be selected by the user when configuring the app via template. While it will make the configuration a bit easier, the time aspect will not be affected as much.

you might find this video (https://salesforce.vidyard.com/watch/X2HcAg2TDD4ZsVoRjUjiwA?) helpful.
Brian LewisBrian Lewis 
I get how to predict in a single object, but there are key fields in another object that are needed to make our prediction worth it. 

How can I get the data from the 2nd object into the 1st object to make a prediction?  
Best Answer chosen by Brian Lewis
Ajeet SinghAjeet Singh
Hi Brain,

Just to add to @jamie, Predictions can be achieved on Einstein Discovery.

Now to answer your question of associating multiple objects on top of 1 parent, you can create dataset which is associated with all other objects linked in specific manner and can select this dataset as outcome for prediction. 
Follow some trailheads to initial prediction, then jump into implementing your use case. Happy learning 
Xie MoXie Mo 
Hi, 

The question below occurs when going through a trailhead but it is not the requirement to pass the trailhead. I just want to find out what is the issue causes this problem.

Trailhead: Einstein Analytics App Design 
Unit: Ask the Right Questions Before You Build Your App (https://trailhead.salesforce.com/content/learn/modules/analytics-app-design/ask-the-right-questions)
Step: Make a Copy of the Motivator Dashboard

When I save the cloned dashboard the following error pops up. I have checked reference lines, and delete widgets etc. and still cannot safe. Does anyone has idea why this is and how to correct it? 

Thank you. 

User-added image
 
Best Answer chosen by Xie Mo
Gauthier MuguerzaGauthier Muguerza
Hello Xie,

There is likely an error with the Reference Lines present on the Dashboard that you are trying to save.
My suggestion is to do the following:


#1. From the Dashboard that you are trying to save, open the JSON file, as explained here:
Use the JSON Editor to modify the JSON for a dashboard (https://developer.salesforce.com/docs/atlas.en-us.bi_dev_guide_json.meta/bi_dev_guide_json/bi_dbjson_modify.htm)

#2. In the JSON file, locate the lines of code that are related to the referenceLines, by hitting Ctrl+F and looking for "referenceLines".

#3. In the JSON file, delete the lines identified above. Save the JSON file.


That should be enough for you to save the Dashboard.

Please let me know if that helps :-)

Best,

Gauthier
Jhili PatraJhili Patra 
Superbadge Einstein Analytics Data Specialist Step 3 Error: We can't validate the 'Create Seed Bank Agencies' node was created correctly. Check the required fields, field types, node name, and alias are correct.

User-added image
Best Answer chosen by Jayson (salesforce.com) 
Divya ChoudharyDivya Choudhary
Sure , Ankush

Here is the JSON:
{
  "Filter Agency Records": {
    "action": "filter",
    "parameters": {
      "filter": "IsAgency:EQ:TRUE",
      "source": "ID Agency Records"
    }
  },
  "Load Account": {
    "action": "sfdcDigest",
    "parameters": {
      "fields": [
        {
          "name": "AccountNumber"
        },
        {
          "name": "Name"
        },
        {
          "name": "ShippingCity"
        },
        {
          "name": "ShippingCountry"
        },
        {
          "name": "ShippingPostalCode"
        },
        {
          "name": "ShippingState"
        },
        {
          "name": "ShippingStreet"
        },
        {
          "name": "Phone"
        }
      ],
      "object": "Account"
    }
  },
  "Create Seed Bank Agencies": {
    "action": "sfdcRegister",
    "parameters": {
      "name": "Seed Bank Agencies",
      "alias": "seed_bank_agencies",
      "source": "Filter Agency Records"
    }
  },
  "Add Agency Fields": {
    "action": "augment",
    "parameters": {
      "right_key": [
        "AccountNumber"
      ],
      "left": "Load Account",
      "left_key": [
        "AccountNumber"
      ],
      "right_select": [
        "Acres",
        "Currency",
        "Latitude",
        "Longitude",
        "Region",
        "SubRegion"
      ],
      "right": "Load Agency Detail",
      "relationship": "AgencyDetail",
      "operation": "LookupSingleValue"
    }
  },
  "Load Agency Detail": {
    "action": "edgemart",
    "parameters": {
      "alias": "Agency_Detail"
    }
  },
  "ID Agency Records": {
    "action": "computeExpression",
    "parameters": {
      "source": "Add Agency Fields",
      "mergeWithSource": true,
      "computedFields": [
        {
          "defaultValue": "FALSE",
          "name": "IsAgency",
          "saqlExpression": "case when Phone is not null then \"TRUE\" else \"FALSE\" end\n",
          "label": "IsAgency",
          "type": "Text"
        }
      ]
    }
  }
}


And here is Dashborad snapshotUser-added image
 
Dan PaulDan Paul 
I can't really see anything special about this user.  I'm using the Log In functionality on the user page.  Some users with the same exact profile/role/permission sets are a able to get into Analytics Studio.  The full error is:
"This page has an error. You might just need to refresh it. Aura.loadComponent(): Failed to initialize application. ui.insights.components.wavePage.WaveModel.appConfig: system.security.IllegalSessionException"

A refresh does nothing, same error.  They have the "Einstein Analytics Platform User" permission set and "Analytics Platform" permission set license.  
Best Answer chosen by Dan Paul
Dan PaulDan Paul
It appears to be related to using the proxy login (the login button on the user record).  We needed to set the user up with Einstein permission set then have them log in directly and access Einstein.  Then we could use the proxy login going forward.
Kelvid PangKelvid Pang 
Hi, 
I am following one of the trailhead module: Extract Salesforce Data into Analytics. I have successfully link the oppportunity, account and user in the data manager. But the schedule was failed. Would like to seek advise on how to troubleshoot/debug this?User-added image
Best Answer chosen by Kelvid Pang
vaibhav raghavvaibhav raghav
Hi Kelvid,

I find the solution for the problem, you have to do Full sync of all opportunities from the connect as shown in the picture.

User-added image 

Once you are able sync all the opportunities, then you again run the Default Salesflow Dataflow. 

User-added image

and it will show status successful under the Job 

User-added image
Katie GuthrieKatie Guthrie 
The dataflow was completed, but the LookupSingleValue node didn't augment any columns. Either the node didn't find any matches, or a join key contains only null values. The dataflow was completed, but the LookupSingleValue node didn't augment any columns. Either the node didn't find any matches, or a join key contains only null values. Data Sync isn’t scheduled for the SFDC_Local connection used in this job. Your data is only as up to date as the last manual sync. Schedule Data Sync from the Connect tab to make sure the job has the latest data.

What can I do to fix this ASAP? Any help would be amazingUser-added image
Best Answer chosen by Katie Guthrie
Deep SinghDeep Singh
Thanks, Katie. Can you mark this answer as best answer :-)

Thanks!