Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
LaTrecesa LeSureLaTrecesa LeSure 
I have no idea how to fix this error. I am trying to install the managed package Dreamhouse per the Trailhead Playground trail. I've even tried using a different sandbox and my developer's copy. I am at a loss.

I moved on to the next Trail because this didn't seem to hold me back from anything but I'd really love to fix this and I want my points and badge. Help!

This app can't be installed.
There are problems that prevent this package from being installed.
Custom Field Definitions(00N4100000eS8Sc) Duplicate RelationshipNameThe relationship name "Favorites__r" is already used by custom field Favorite__c.Property__c. Please rename existing relationship name.
Best Answer chosen by LaTrecesa LeSure
Greg OwenGreg Owen
You need to update the relationship name of the that custom field... the app is trying to install on with the same name. Go to the custom field listed and edit the related list name change it to Favorites2
Brian Ferguson ☁️Brian Ferguson ☁️ 
I'm trying to finish the beginner Admin trailhead module but I can't download an app from the app exchange into my Trailhead Playground instead it attempt to download into my PRD ORG.  I sign into Trailhead with my PRD creditals.

Does anyone know what I am doing wrong here?  Please help!
Best Answer chosen by Brian Ferguson ☁️
Harisha KodaliHarisha Kodali
When you try downloading the app from APp exchange, it asks for the login credentials. Try giving a Developer ORg credentials, where the Developer Org is connected to Trailhead.

Else, you can have option to loginto Trailhead Playground, when you try completing the challenge.User-added image

You can loginto One of the Playground. In the user record. Reset the password, so that you can use those credentials to login to app exchnage.

Hope this Helps!
Alexander PeckAlexander Peck 
Last night approx. 4:45 PM MT we were able to successfully build packages using the SFDX CLI. Starting approx. 8 AM MT today even attempting to build the exact same code yields this error across many projects (which we've successfully built hundreds of times in the past):

"ERROR running force:package:version:create: Admin: An object 'Admin' of type Profile was named in package.xml, but was not found in zipped directory"

We checked our dev hub status (which is associated with NA66) and see no maintenance or known issues posted. No upgrade has been done either. Has anyone experienced or knows what this issue is?
Best Answer chosen by Alexander Peck
Alexander PeckAlexander Peck
Further update: a dependency, salesforcedx, 49.8.0 published a day ago. 49.7.0 does not have the issue.
Jane MarchandJane Marchand 
I'm trying to deactivate an apex class
I've marked it as inactive in sandbox and tried deploying it to live
but I get an error saying a class cannot be marked as inactive!
Best Answer chosen by Jane Marchand
Richard ClarkRichard Clark
Jane, you can't deactivate an Apex Class, you can deactivate an Apex Trigger. If you need to deactivate code (say to rename the API name of a custom field) you need to comment out the relevant code, make the change, then uncomment.

If you need to make the change in production you need to do it in a dev sandbox first, publish the commented out/deactivated versions make your changes, then re-publish the uncommented ones!

I also have a nifty trick for building code that can be automatically disabled using Hierarchical Custom Settings if you're interested.
Dan MacDan Mac 
We are using Nonprofit Success Pack (NPSP). I have done some search but could not find how to install Volunteers for Salesforce (V4S). There is a article "Volunteers for Salesforce (V4S) Knowledge Article Number 000317276" but when I click on the help link and it comes up "Oops! It looks like something went wrong." Any help and tips are appreciated.

Best Answer chosen by Dan Mac
Richard PomeroyRichard Pomeroy

Hi Dan, thanks for your question. I have not done much direct work on the NPSP myself, however, I have done a quick search for you and found the following:

I believe this should give you the information you require. Follow the prompts (including navigating to the V4S Installer - and you should be all set.

I hope this helps. If this has answered your question, please mark this as answered. Thanks!

Ken VermillionKen Vermillion 
I installed map plotter as an Admin from the App Exchange.  I then went back and "upgraded" and forced full access level on users with a specific profile

When I log in as a non-Admin user, they can see the new App at the top, can click it, but it loads an issufficient privilegs error.

Under the Profile > Object settings, the only setting for this app is Default On...there are no other options.

Best Answer chosen by Bhavin ( 
Jayson MoralesJayson Morales
Hi Ken, 

Try to go to Setup > Permission Sets and look for MPV2UserPermissionSet and assign to one of your users. Try to access the app again after assigning that permission set.

Hope that helps.

Dani PreyDani Prey 
Should there be any issue having the same app installed and configured in both Production and Sandbox enviornments? Is there anything I should be aware of? Thank you!
Best Answer chosen by Dani Prey
Ankush DurejaAnkush Dureja
You can have app in both production adn sandbox. There is no issue. Sandbox and production are separate environment and are independent of each other. But you need to take care of the following things:
If you have integration with 3rd party app, make sure that your sandbox environment is not connected to same instance of 3rd party app. It should also be sandbox kind of or test environment.
Vilmarir PaganVilmarir Pagan 

Is anyone using this app, org Chart - Lightning Ready and can tell me a bit of how it works within your company? What do you with users who do not have actual licenses?
Best Answer chosen by Vilmarir Pagan
Abhishek SinhaAbhishek Sinha
Really nice un-managed package which gives nice visualisation of your Org Structure.
Has really helped us when rolling out a project that needed the users to have a clear view of their reporting lines in Salesforce.

Tim WallaceTim Wallace 
Hi all,

My team and I have been using Non-Profit Success Pack for a few years.  We updated our Salesforce to Lightning Experience last fall with no complaints.  Something changed in the Spring Release that moved all of our roles to the default home page despite my having assigned each of our roles their own home page.  I tried to re-assign them through the activation button when editing a home page, but the NPSP app doesn't show up as available to edit assignements.  I went into app manager, and I can see the despite having migrated to Lightning, NPSP is still a "classic" app, and there's no obivious action to take to upgrade it.  What am I missing?  How do I upgrade my NPSP app to lightning so I can fix my home page assignments?  Thanks.
Best Answer chosen by Tim Wallace
Tiia GrodenTiia Groden
Turns out the NPSP app thats brought over when you swap to Lighting is a Classic "app" and you just need to create a custom NPSP App for Lighting following these instructions!
Rebecca CzyzRebecca Czyz 
I am having a heck of a time uninstalling a package from my org. I keep getting the error that I have a permission set assigned to users under one of my inactive sites. When I go into the site there are no assignments. (screen shots below) Help! User-added imageUser-added image
Best Answer chosen by Rebecca Czyz
Om PrakashOm Prakash
Have you checked for all available Sites in org?
As per error message, there might be one user. (Site guest user).

If you have checked all sites of this org and still same error while uninstalling then I would suggest reaching Salesforce Support team for internal troubleshooting.